Jump to content
Invision Board France
Sign in to follow this  

Vous avez un problème avec les caractères accentués �


iProxy

Vous avez un problème avec les caractères accentués ? et pourtant vous êtes en UTF-8 !

 

Pour visualiser le problème plus facilement, il faut utiliser l'application : TOR

 

Exemple du problème : G�rer les fichiers d'aide, T�l�chargements, d�cembre, r�ponse :angry:

 

Mail : Certains de vos membres réceptionnent les notifications par mail avec les caractères accentués non conforme.

Forum : D'autre lorsqu'il poste les messages dans le forum ne voie pas les caractères accentués dans le skin membre.

Message : certains membres lorsqu'il envoie des messages privés les caractères accentués sont remplacés par √%&@…

CP-Admin : Dans la partie CP-Admin j'ai des �

 

Valeur par défaut en (vert)

 

_______________________________________________________

• Avant de vous lancer dans ces modifications il faut mettre votre forum (OFFLINE) :

CP-Admin -> System -> Paramètres -> Community Offline / Online

 

Turn the community offline (OUI)

 

Attention :
Puis faire un backup intégral (FTP + MySQL), avant de vous lancer dans cette aventure !
:(

_______________________________________________________

• Votre pack Langue et non identifiable par les explorateurs :
(sans risque)

CP-Admin -> Languages

 

Par défaut Français : fr_FR

- il faut le modifier par : fr_FR.UTF-8

 

Par défaut English : en_US

- il faut le modifier par : en_US.UTF-8

_______________________________________________________

• Votre serveur ne respect pas le UTF-8 défini dans IPS :
(Cela ma réglé mon bug)

CP-Admin -> System -> Character conversion method

 

Par défaut : internal

- Il faut le changer : iconv

 

- Si il reste des zones à problème : mb functions

 

Attention :
tout les Hosting ne support pas ces valeurs donc vérifier dans leur FAQ.

_______________________________________________________

• Votre Base de donnée est non conforme :
(50% de chance que cela marche)

CP-Admin -> Gestion SQL -> Variables système SQL

 

Cherchez dans la page :
latin1
ou autre qui ne serait pas UTF-8

 

Si vous avez cela, IPS recommande d'utiliser le script suivant :

 

 

Attention :
IPS décline toute responsabilité en cas de problème avec ce script et vous n'aurez aucun support.

_______________________________________________________

• Puis lorsque vous utilisez l'un de ces choix il faut reconstruire les caches :

CP-Admin -> System -> Gestion du cache

 

Tout reconstruire

_______________________________________________________

• N'oubliez pas de rouvrir votre forum après une batterie de tests :

CP-Admin -> System -> Paramètres -> Community Offline / Online

 

Turn the community offline (NON)

 

 

Bonne chance !
:huh:
Sign in to follow this  


User Feedback

Recommended Comments



Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.