Jump to content
Invision Board France
  • 0
Sign in to follow this  
kosmos1999

4.4 [3.4 -> 4.X] erreur durant l'upgrade

Question

kosmos1999

Bonjour,

Mon upgrade 3.4 vers 4.x (sur un serveur local) a planté en cours.

J'ai donc remis mon serveur en php 5, restauré ma base de données, réinstallé la sauvegarde des forums, reconnecté l'ensemble.

Une fois que tout était fonctionnel, j'ai effacé tous les répertoires sauf Public et Uploads, tous les fichiers sauf conf_global.php et constants.php.

J'ai repassé PHP en 7 et j'ai relancé l'upgrade.

Mais malgré tout ça, il détecte toujours que j'ai un upgrade en cours et bloque toujours la fin de l'upgrade.

Avez-vous une idée de ce qu pourrait bloquer ?

image.png.71c56d6baa46098ed0ff0f19ae7d3a06.png

image.thumb.png.379b3a155d27dc2b9ac79e644303485d.png

 

Merci d'avance de votre aide.

Edited by kosmos1999
ajout d'une copie d'écran plus nette

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0
Youp3

Bonjour,

 

quand tu indiques avoir restauré ta base de données, l’avais-tu entièrement supprimée avant ?

De plus avant de relancer l’upgrade, il faudrait que tu vérifies via l’outil du PCA que ta base est bien intègre (pas de table ou de champ manquant).

Share this post


Link to post
Share on other sites
  • 0
kosmos1999

Oui, j'avais supprimé la base (cliqué sur la base, puis Drop)

Comment je vérifie via l'outil du PCA ? Tu veux dire sur la version de départ, celle en version 3.4 ? Ou il existe un outil autonome permettant de checker ?

Share this post


Link to post
Share on other sites
  • 0
Youp3

Sur la version 3.4, il y a de mémoire un outil qui vérifie et peut corriger ce genre d’erreur. Par contre sans accès au PCA, je suis incapable de t’indiquer où il se trouve. Cela fait un moment que je n’ai pas utilisé la branche 3.4.

Share this post


Link to post
Share on other sites
  • 0
kosmos1999

Bonjour,

Après une longue absence, je retente la migration de mon forum.

 

J'ai donc :

- réinstallé la sauvegarde de ma base de données (entièrement vidée via PhpMyAdmin sur mon serveur local)

- Remis langue en English

- Effacé toutes les actions en cours dans l'espace modérateurs

- Désinstallé tous les hooks et tous les add-ons

- Via le support du PCA :

  • Whitespace checker : corrigé tous les fichiers avec des whitespaces
  • Permission checker : ok
  • connexion checker : OK
  • Database checker : OK
  • Database Index Checker : OK

 

J'ai ensuite passé le script : ALTER TABLE table_XXX ENGINE=InnoDB;

Sur toutes les tables de ma base de données

 

J'ai tout effacé sauf Public, Admin, Conf_global et constants et j'ai lancé l'upgrade.

 

Tout s'est bien passé jusqu'à l'upgrade à proprement dire. Au bout de quelques secondes, j'ai le message d'erreur suivant : 

Citation

La colonne 'mlog_content' de type BLOB est utilisée dans une définition d'index sans longueur d'index

 

image.thumb.png.970a9c8b69b4b339afb077b55d9865ac.png

 

Avez-vous une idée de ce je dois faire (impossible de trouver le même problème sur internet)

 

Merci d'avance de votre aide.

Share this post


Link to post
Share on other sites
  • 0
Youp3

Bonsoir,

 

Alors moi quand depuis phpmyadmin je consulte la structure de la table core_mail_error_logs, j’ai ceci :

image.thumb.png.7513103e4475f8581fef02785501cda4.png

 

En bas dans la partie index, il n’y a pas d’index sur la colonne mlog_content.

Si toi tu as un index dessus, alors tu dois pouvoir le supprimer.

 

Autre point : je ne suis pas certain que c’était une bonne idée de passer en InnoDB toutes tes tables. Car justement InnoDB utilise les BLOB si je me souviens bien.

 

En espérant que cela puisse t’aider à résoudre ton problème.

Share this post


Link to post
Share on other sites
  • 0
Youp3

Bon, vérification faite, la table core_mail_error_logs est bien en innoDB sur mon installation de test. Par contre toutes les tables ne le sont pas. Certaines demeurent en MyISAM.

Share this post


Link to post
Share on other sites
  • 0
kosmos1999
Il y a 14 heures, Youp3 a dit :

je ne suis pas certain que c’était une bonne idée de passer en InnoDB toutes tes tables

Je l'ai fait suite à ce post qui m'a permis de passer l'étape de la conversion sans encombres

 

Je dois avoir des problèmes d'index, car de mon côté, voilà ce que j'ai :

image.thumb.png.0ddb9a92bda8d9a083765e1f4826504d.png

Share this post


Link to post
Share on other sites
  • 0
cybero

Pour info ma table core_mail_error_logs est identique à celle de Youp3

 

Il y a 15 heures, Youp3 a dit :

Si toi tu as un index dessus, alors tu dois pouvoir le supprimer.

 

Je vote pour la suppression des index en trop par rapport à la capture un peu plus haut.

 

 

Concernant InnoDB j'ai vu plusieurs fois sur la communauté IPS un encouragement à tout basculer.

Cette semaine encore:

https://invisioncommunity.com/forums/topic/456226-server-management-best-practises/

 

Par contre là encore comme Youp3, j'ai une partie des tables en MyISAM et l'autre en InnoDB.

Ce n'est pas tout en InnoDB par défaut même si à priori ça ne pose aucun problème.

 

Edited by cybero
Complément InnoDB

Share this post


Link to post
Share on other sites
  • 0
kosmos1999

J'ai effectivement supprimé tous les index qui ne sont pas sur la capture d'écran de Youp3 et je l'ai refait à chaque autre message d'erreur durant l'upgrade qui a bien avancé, mais qui est maintenant bloqué par ce message :

Citation

La clé est trop longue. Longueur maximale: 1000
C:\wamp\www\forums\system\Application\Application.php::1636


ALTER TABLE `cbv_forums_forums_topics` ENGINE=MyISAM, ADD KEY `most_recent_post` (`forum_id`,`approved`,`last_post`)

J'ai essayé de modifier MyISAM par InnoDB, mais rien à faire

Share this post


Link to post
Share on other sites
  • 0
kosmos1999

Bon, au final, chaque fois que ça bloque sur une table, j'efface tous les index, sauf le PRIMARY et l'upgrade a fini par aller jusqu'au bout.

 

Il me reste plus qu'à uploader tout le site et importer la base de données sur mon hébergement et apprivoiser la bête :)

 

Un grand merci pour votre aide !! 👍

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.