Jump to content
Invision Board France
  • 0
blade11

4.3 Affichage inapproprié de dates

Question

blade11

Bonjour à la communauté.

 

Comment je vais expliquer cela simplement ?

J'ai une erreur d'affichage de dates uniquement sur mobile smartphone.

Je pense qu'il s 'agit d'une absence ou d'une erreur de traduction

 

exemple :

A la place de "il y a 28 minutes"

s'affiche "%d min"

 

A la place de "il y a 10 heures"

s'affiche "%d h"

 

Seules les dates apparaissant dans des blocs avec listes semblent affectés comme celui du Flux des sujets par exemple.

 

Est-ce le fichier ibf_core_sys_lang_words qu'il faut modifier et si oui, comment ?

 

Pour info, ce fichier indique ceci :

word_default : {#[0:min][1:min][?:min]}

word_custom : %d min

 

Merchi ! 😴

 

 

 

 

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0
cybero

Bonjour :)

 

il ne faut pas modifier dans le fichier (ni dans la base) mais passer par l'outil de traduction dans le PCAdmin, c'est plus simple :)

 

Mais c'est curieux, je ne trouve pas les valeurs indiquées dans le fichier de traduction de la 4.3

Quelle est la clé de la chaîne que tu cites ?

Le plus approchant que je trouve sont les chaînes

f_minutes_short
f_hours_short
f_days_short

 

Mais pour moi leur traduction est correcte dans la dernière version de la traduction disponible

 

Tu es bien en 4.3 avec ce dernier fichier de traduction ?

 

Share this post


Link to post
Share on other sites
  • 0
blade11

Bonjour,

 

C'est agréable d'avoir une réponse. :)

 

Oui, mon 1er réflexe a été également de passer par l'outil de traduction. Et comme toi, je n'ai pas trouvé. Du coup, j'ai cherché un autre biais.

il y a 15 minutes, cybero a dit :

u es bien en 4.3 avec ce dernier fichier de traduction ?

 

Je suis bien en 4.3, mais pour le dernier fichier de traduction, je ne suis pas certain, il me semble que oui, il faut que je vérifie. Cependant tu me dis ne pas trouver de toute façon autre chose.

 

La clé de la chaîne est bien f_minutes_short, f_hours_short et f_days_short

 

Cela ne vient pas du thème spécifique que j'utilise en tout cas, car le thème par défaut a le même souci. 

 

Ca doit être un problème simple pourtant.

Share this post


Link to post
Share on other sites
  • 0
cybero
Il y a 4 heures, blade11 a dit :

Je suis bien en 4.3, mais pour le dernier fichier de traduction, je ne suis pas certain, il me semble que oui, il faut que je vérifie. Cependant tu me dis ne pas trouver de toute façon autre chose.

 

Pourrais-tu essayer de réinstaller la dernière version du pack FR pour voir ?

 

Sinon, dans le PCAdmin, qu'as-tu pour les 3 clés en question ?

Je pourrai te donner les bonnes valeurs à mettre si besoin :)

Share this post


Link to post
Share on other sites
  • 0
blade11
il y a 38 minutes, cybero a dit :

Pourrais-tu essayer de réinstaller la dernière version du pack FR pour voir ?

 

Bonne nouvelle, ça a résolu le souci, les dates / heures s'affichent correctement désormais sur mobile ! 

 

Merci à toi. Je n'avais probablement pas la dernière version de la traduction. Si ça peut servir à d'autres, le bug se résout facilement.

Edited by blade11
  • Like 1

Share this post


Link to post
Share on other sites
  • 0
cybero

Ah tant mieux :fleur:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.