Jump to content
Invision Board France
  • 0
dragon76

4.3 soucis dans l'admin cp

Question

dragon76

Bonjour a toute et a tous, avant tout chose je vous souhaite une bonne année et surtout une bonne santé,

 

je ces pas si je poste au bonne endroit mais un soucis, des que je suis dans l'admin pc j'ai ceci qui apparait

"Nous vous recommandons de désactiver les fonctions suivantes sur votre serveur, ou au moins dans le dossier dans lequel votre communauté est installée. Si vous ne gérez pas votre serveur vous-même, votre hébergeur devrait pouvoir vous aider à le faire.
exec, proc_open", que doit-je faire?

 

dans l'attente d'une réponse je vous souhaite une bonne journée.

 

cordialement.

Share this post


Link to post
Share on other sites

10 answers to this question

Recommended Posts

  • 0
Youp3

Bonjour @dragon76,

 

Il s’agit d’une mesure de sécurité. Il faut dans la configuration de php désactiver ces fonctions considérées comme dangereuses. Donc soit ton hébergeur te permet de le faire toi-même via un fichier, soit tu demandes à ton hébergeur de le faire pour toi.

 

Bonne journée.

Share this post


Link to post
Share on other sites
  • 0
dragon76

boujour @Youp3 j'ai demander a mon hébergeur, il mon dit que c'était normal pour des raisons techniques et de configurations 

Share this post


Link to post
Share on other sites
  • 0
Youp3

Il ne s’agit clairement pas d’une bonne pratique d’avoir ces deux fonctions activées.

Moi je songerais à changer de crèmerie si c’est la réponse définitive.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
Zorro_X
Il y a 13 heures, Youp3 a dit :

soit ton hébergeur te permet de le faire toi-même via un fichier

 

c'est parfois possible via le fichier de config php (ou le .htaccess ?), mais je ne me rappelle pas de ce qu'il faut indiquer pour ça, t'as des infos à ce propos ?

Share this post


Link to post
Share on other sites
  • 0
Youp3

Dans le fichier php.ini, il faut avoir la ligne suivante :

disable_functions = exec, system, pcntl_exec, popen, proc_open, shell_exec

 

Share this post


Link to post
Share on other sites
  • 0
dragon76
Il y a 5 heures, Youp3 a dit :

Dans le fichier php.ini, il faut avoir la ligne suivante :


disable_functions = exec, system, pcntl_exec, popen, proc_open, shell_exec

 

 

j'ai fait une recherche je ne les pas dans ce fichier

Share this post


Link to post
Share on other sites
  • 0
cybero

Il faut vérifier si ton hébergeur permet ou non la personnalisation du php.ini

 

C'est parfois pas le cas du tout

C'est parfois pas le cas par défaut et il en faire la demande  et / ou activer via ton interface chez ton hébergeur

C'est parfois pas le cas par défaut et il "suffit" de créer et placer ce fichier php.ini au bon endroit (cf FAQ de ton hébergeur)

 

Par exemple chez mon hébergeur il faut procéder de la sorte: 
Choisir la version de PHP et personnaliser son fichier php.ini

 

Mais bon vue cette réponse  🙄

 

Le 23/01/2019 à 10:48, dragon76 a dit :

boujour @Youp3 j'ai demander a mon hébergeur, il mon dit que c'était normal pour des raisons techniques et de configurations 

 

 

Bon courage :)

 

Edited by cybero

Share this post


Link to post
Share on other sites
  • 0
Zorro_X

Est-ce-qu'il y a un moyen de forcer le PCA à vérifier que ces paramètres sont OK ?

Il me semblait que dans les versions précédentes il y avait moyen, mais là je ne retrouve plus... 😕 

Share this post


Link to post
Share on other sites
  • 0
Youp3
Il y a 12 heures, Zorro_X a dit :

Est-ce-qu'il y a un moyen de forcer le PCA à vérifier que ces paramètres sont OK ?

Il me semblait que dans les versions précédentes il y avait moyen, mais là je ne retrouve plus... 😕 

 

C’est effectivement quelque chose qui a disparu. C’est vérifié automatiquement et affiché uniquement si besoin.

Share this post


Link to post
Share on other sites
  • 0
Zorro_X
Il y a 6 heures, Youp3 a dit :

 

C’est effectivement quelque chose qui a disparu. C’est vérifié automatiquement et affiché uniquement si besoin.

 

Je me disais aussi... Merci !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.