Aller au contenu
Invision Board France
  • 0
julien416

4.3 Problèmes après passage HTTPS

Question

julien416

Bonjour,

Pour mon premier message, malheureusement je commence avec un problème. J'administre un petit forum sous IPB en version 4.3.6 qui existe depuis une douzaine d'années. J'ai récemment décidé de passer en https comme mon hébergeur (infomaniak) me le recommandait. Seulement voilà après passage en https et modification de mon conf_global en suivant les instructions du lien suivant (https://invisioncommunity.com/4guides/advanced-options/configuration-options/using-ssl-https-r273/) je n'arrive plus à naviguer sur mon forum. Le moindre clic sur un sous forum me ramène directement à la page d'accueil. Idem pour tout à vrai dire. Seul l'accès au pc Admin fonctionne encore. 

J'avoue que je sèche un peu. J'ai effacé le cache comme c'était indiqué sans succès. Une idée ?

Merci d'avance !

 

Partager ce message


Lien à poster
Partager sur d’autres sites

5 réponses à cette question

Messages recommandés

  • 0
Zorro_X

T'as un certificat SSL valable pour ton nom de domaine et le sous-domaine www. ?

T'as re-saisi ton numéro de licence pour valider le https auprès d'IPS ?

T'as jeté un oeil au fichier .htaccess de ton hébergement ? à mon avis tu dois encore avoir des redirections en http:// , ce qui peut expliquer le renvoi systématique à la page d'accueil.

 

 

 

Modifié par Zorro_X

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
julien416

Bonjour et merci pour la réponse !

Oui mon certificat ssl couvre tous mes sous domaine.

Oui pour le numéro de licence ! Je l'ai revalidé.

A la racine du forum et du site j'ai un htaccess avec les lignes suivantes pour forcer le https

 

Citation

RewriteEngine On
RewriteCond %{HTTPS} on
RewriteRule .* https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]

 

Je nage toujours :(

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Zorro_X

c'est bizarre, je n'arrive plus à retrouver le paramètre mais normalement t'as quelque part dans le PCA un bouton à tourner pour passer à un mode de connexion sécurisé (https) et t'as le choix de le faire uniquement pour le PCA ou pour tout le site... :/

cherche "https" ou "ssl" dans le PCA, peut-être trouveras-tu quelque chose d'utile... je vais continuer à chercher, mais comme je suis déjà en https, je soupçone l'interface d'avoir "disparu" (genre : opération non réversible)... :/

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
MasterGone
Le 19/12/2018 à 22:26, Zorro_X a dit :

c'est bizarre, je n'arrive plus à retrouver le paramètre mais normalement t'as quelque part dans le PCA un bouton à tourner pour passer à un mode de connexion sécurisé (https) et t'as le choix de le faire uniquement pour le PCA ou pour tout le site... 😕

cherche "https" ou "ssl" dans le PCA, peut-être trouveras-tu quelque chose d'utile... je vais continuer à chercher, mais comme je suis déjà en https, je soupçone l'interface d'avoir "disparu" (genre : opération non réversible)... 😕

 

Je confirme et il y a également un nouveau fichier .htacess à télécharger dans le PCA et à placer à la racine du forum.

Modifié par MasterGone
  • Merci 1

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Youp3

Bonjour,

 

Votre demande de support ne pourra être traitée si vous ne fournissez pas un minimum d’informations comme la version, l’hébergeur, l’adresse, les mods installées etc…

Voici un exemple :

URL de vos forums : https://www.invisionboard.fr/forums

Version : Community Suite 4.1.x

Hébergeur : Phpnet

Version de PHP : 7.0.14

Version de MySQL : 5.5.6

Les mods : Non

Skins : Le standard

 

Des champs de votre profil membre sont dédiés à ces informations. Merci de les compléter, cela vous évitera de devoir donner ces informations à chaque sujet.

Ces informations sont privées et ne sont consultables que par les membres de notre équipe technique.

 

Ceci est une réponse automatique :)

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×

Information importante

En utilisant ce site, vous êtes d’accords avec nos Conditions d’utilisation. Nous avons placé des cookies sur votre appareil pour aider à améliorer ce site. Vous pouvez choisir d’ajuster vos paramètres de cookie, sinon nous supposerons que vous êtes d’accord pour continuer.