Aller au contenu
Invision Board France
  • 0
iProxy

4.3 Bug pénible avec les caractères accentués dans les URL.

Question

iProxy

Depuis un long moment j’ai quelques visiteurs qui ne parviennent à entrer sur mon site web erreur 404, en cause les URL qui comportent des caractères accentués. Pour pallier à ce problème j’ai créé des redirections avec des URL plus courts, au fils des mois c’est devenu ingérable.

 

J’ai donc ouvert de nombreux tickets de support auprès de invisionpower. Mais à chaque fois la réponse reste la même: il faut que vous supprimiez les modules annexes, que vous utilisiez un explorateur à jour, un os plus récent sans vraiment faire une réelle investigation.

 

Puis c'est au tour des moteurs de recherche. Je constate des anomalies au niveau du sitemap qui ne n'est pas pris en compte, en cause des URL aberrant. Là encore les pages génèrent des erreurs (404), le seul point commun est qu’il y a des caractères accentués dans les URL.

 

N’ayant pas assez de recul sur le problème, j’ai demandé à tous mes membres de faire des tests en leur fournissant des liens web incorporant des caractères accentués. Approximativement 15% d’entre eux ont été confrontés à la problématique. Qui se traduit par une erreur (404) lors de l’accès la page demandée, mais ce n’est pas constant. Invision me répond que les usagés devraient modifier de leur propre initiative l’URL lorsqu'il pose problème! un non-sens.

 

Après des mois de test dans des virtualisations, j’ai découvert qu’invision ne respecte toujours pas à 100% le UTF-8 et co dans l’affichage. Pour palier a ce bug invision à créée une sorte de module pour compenser l’erreur. Le premier URL est celui fournir par le site web et le second a été modifier pour supprimé tout les caractères accentués comme recommander tous les deux fonctionnent.

 

  1. https://www.nospy.ch/info/forums/topic/28822-des-publicités-non-sollicitées-ont-été-imprimées-sur-mon-imprimante-hp/
  2. https://www.nospy.ch/info/forums/topic/28822-des-publicites-non-sollicitees-ont-ete-imprimees-sur-mon-imprimante-hp/

 

Pourtant si je créer dans le module Pages une zone pour les URLs ils sont afficher comme suit (c'est ce type de URL qui me pose des problèmes) :

 

 

(MAJ: En voulant mettre le lien web ci-dessus dans le support en Invision le lien a été automatiquement corrigé pour l'afficher correctement, ce qui n'a pas été en cas dans ce forum).

 

En cherchant sur internet j’ai découvert que de nombreux webmasters ont des problèmes similaires avec les CMS qui génèrent des caractères accentués. Ces bugs aberrants ont été résolus très simplement en supprimant les caractères accentués dans les URL. Toutes mes demandes auprès d’invision sont restée veine. 

 

Il suffirait d’ajouter le code ci-dessous, je ne sais où pour mettre un terme à ces caractères accentués dans les URL.

function formatrewriting($chaine){
 $chaine=trim($chaine);
 $chaine= strtr($chaine,"ÀÁÂÃÄÅàáâãäåÒÓÔÕÖØòóôõöøÈÉÊËèéêëÇçÌÍÎÏìíîïÙÚÛÜùúûüÿÑñ","aaaaaaaaaaaaooooooooooooeeeeeeeecciiiiiiiiuuuuuuuuynn");
 $chaine = preg_replace('/([^.a-z0-9]+)/i', '-', $chaine);
 return $chaine;
}

 

Questions:

  1. Où placer ce code ?
  2. Comment faire pour qu'Invision, ajoute l'option de désactiver les URL a caractère accentué (feedback)?
Modifié par iProxy

Partager ce message


Lien à poster
Partager sur d’autres sites

5 réponses à cette question

Messages recommandés

  • 0
blade11

Bonjour,

Est-ce que tu as finalement trouvé où placer ce code, ta réponse m'intéresserait car je suis confronté au même problème apparemment.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
iProxy

Non,

 

Ce code ne fonctionne pas, car IPB utilise plusieurs modules pour gérer les URLs (forum, blog, gallerie…). Il faudrait placer ce code a plusieurs endroit ou faire une librairie, ce qui dépasse mes compétences.

Modifié par iProxy

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
iProxy

Il faudrait faire pression pour que IPB règle le problème. Vous pouvez aussi répondre au sujet posté par NoSpy, comme cela il remonte dans le fils des discutions.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Zorro_X
Il y a 11 heures, iProxy a dit :

Il faudrait faire pression pour que IPB règle le problème. Vous pouvez aussi répondre au sujet posté par NoSpy, comme cela il remonte dans le fils des discutions.

fait !

  • Merci 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×

Information importante

En utilisant ce site, vous êtes d’accords avec nos Conditions d’utilisation. Nous avons placé des cookies sur votre appareil pour aider à améliorer ce site. Vous pouvez choisir d’ajuster vos paramètres de cookie, sinon nous supposerons que vous êtes d’accord pour continuer.