Jump to content
Invision Board France
Sign in to follow this  
thewiseoldman

Protéger ses images et sa bande passante.

Recommended Posts

GreG_WMN

Suffit de mettre :

RewriteEngine on

RewriteCond %{HTTP_REFERER} !^$

RewriteCond %{HTTP_REFERER} !^http://www.aaahhhbeurk.webdynamit.net/.*$ [NC]RewriteCond %{HTTP_REFERER} !^http://www.membres.lycos.fr/aaahhhforum/.*$ [NC]

RewriteRule \.(gif|jpg|GIF|JPG|rmi|mid|MID|rm|wav|WAV)$ http://membres.lycos.fr/aaahhhbeurk/bannie...aahhhbeurk4.gif [R,L]

 

:)

Share this post


Link to post
Share on other sites
Bébé
ReWriteRule .*\.(gif|png|jpe?g)$ - [F]

C'est normal le ? dans l'extention jpeg ?

DE plus ça a pas été dit mais je suppose que l'on peut protéger les fichiers que l'on veut : zip, mpeg, ...etc

 

Sinon j'ai créé placé mon .htaccess sur un répertoire de mon serveur chez nexlink en leur ayant demandé d'y activer le htaccess.

Mon fichier contient donc :

RewriteEngine on
RewriteCond %{HTTP_REFERER} !^$
RewriteCond %{HTTP_REFERER} !^http://www.celinecommunity.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.celineangelil.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://celinecommunity.ipbhost.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.celinecommunity.ipbhost.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.startop.net/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.madonna-forum.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.berizzi.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://bruno.berizzi.com/.*$ [NC]

ReWriteRule .*\.(zip|mpeg|mpg|gif|png|jpg|jpe?g)$ - [F]      

Depuis celinecommunity.com, j'ai plus accès ni aux images ni aux fichiers que je veux autoriser.

Par exemple à la place de l'image en jpg, il y a d'écrit USER POSTED IMAGE

 

 

Merci

Edited by Bébé

Share this post


Link to post
Share on other sites
Bébé

Merci Gilles. J'ai fais cela et c'est idem.

Mon fichier modifié :

RewriteEngine on
RewriteCond %{HTTP_REFERER} !^$
RewriteCond %{HTTP_REFERER} !^http://www.celinecommunity.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://celinecommunity.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.celineangelil.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://celinecommunity.ipbhost.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.celinecommunity.ipbhost.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.startop.net/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.madonna-forum.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.berizzi.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://bruno.berizzi.com/.*$ [NC]

ReWriteRule .*\.(zip|mpeg|mpg|gif|png|jpe?g)$ - [F]      

Pour un fichier zip hébergé voila ce que ça me met :

  The server encountered an internal error or misconfiguration and was unable to complete your request.

J'y comprend rien, ça devrait fonctionner :unsure:

Share this post


Link to post
Share on other sites
Bébé

Mon serveur accepte bien le rewrite_mod

 

Par contre est-ce que le fait d'avoir un ou 2 *.htaccess en amont ne provoque pas cette anomalie ?

Share this post


Link to post
Share on other sites
guymauve

tu peux nous donner un lien d'un zip par ex ???

 

A+

Share this post


Link to post
Share on other sites
Bébé

Pour rentrer dans le répertoire il faut un login et password mais je vais essayer de paramétrer cela dans un dossier non protégé que vous voyez ce que cela fait.

Share this post


Link to post
Share on other sites
Bébé

Bonjour, j'ai trouvé un truc sympa et radical semblerait-il pour se protéger des voleurs d'images ou cherchant à télécharger de gros fichiers sur votre site afin d'augmenter la consommation de bande passante. Il s'agit aussi d'un htaccess contenant ceci :

<FilesMatch "\.(jpg|gif|png|zip)$">
SetEnvIfNoCase Referer "http://www.votre_domaine.com/" local_referer=1
Order Allow,Deny
Allow from env=local_referer
</FilesMatch>

Cela redirige sur une page d'erreur 403 mais je sais qu'il est possible de rediriger vers une page e son choix. J'ai créé une page pour effrayer les plaisantins http://www.berizzi.com/stol.htm

 

Quelqu'un saurait comment modifier mon htaccess pour que se soit cette page et pas la 403 qui soit utilisée.

 

Merci

Share this post


Link to post
Share on other sites
Malouk
Quelqu'un saurait comment modifier mon htaccess pour que se soit cette page et pas la 403 qui soit utilisée.

 

Merci

 

Pourquoi ne pas rediriger l'erreur 403 pour le dossier qui contient les téléchargement sur ta page via le .htaccess ?

 

Il suffit d'ajouter cette ligne :

 

ErrorDocument 403 http://www.berizzi.com/stol.htm

Share this post


Link to post
Share on other sites
Strat
Sur le même principe et suite à une colle posée par Simous voici comment protéger vos fichiers attachés :
RewriteCond %{HTTP_REFERER} !^$

RewriteCond %{HTTP_REFERER} !^http://ibf-french.com/.*$ [NC]

RewriteCond %{HTTP_REFERER} !^http://www.invisionboard.fr/forums/.*$ [NC]

RewriteCond %{HTTP_REFERER} !^http://beta.ibf-french.com/.*$ [NC]

RewriteCond %{QUERY_STRING} .*Attach* [NC]

RewriteRule ^.*$ http://membres.lycos.fr/ibffrench/referrer.gif [L,R]

Donc pour tous les referers qui ne seront pas dans la liste et pour toute query_string contenant Attach la requête sera redirigée vers lycos.

 

Ba moi ca fonctione tjr pas... :)

 

Quand je met un lien de fichier atacher sur mon forum sur un autre... Ils peuvents quand meme telecherger. Paeil quand il sagit de voir une image en grand.

 

Je pige pas :)

Share this post


Link to post
Share on other sites
Poppy
RewriteCond %{HTTP_REFERER} !^$

RewriteCond %{HTTP_REFERER} !^http://ibf-french.com/.*$ [NC]RewriteCond %{HTTP_REFERER} !^http://www.invisionboard.fr/forums/.*$ [NC]

RewriteCond %{HTTP_REFERER} !^http://beta.ibf-french.com/.*$ [NC]

RewriteCond %{QUERY_STRING} .*Attach* [NC]

RewriteRule ^.*$ http://membres.lycos.fr/ibffrench/referrer.gif [L,R]

 

Merci mille fois, je viens de tester, c'est trop bien :lol:

 

Car même qd on enregistre une image (icone pour notre exemple), sur le disque dur, c'est en faite 'referrer.gif' avec le nom de l'icône qu'on voulait enregistrer :)

 

Un seul petit point négatif, c'est de mettre le .htaccess dans chaque répertoire, je n'y connais rien, mais ça serait mieux de bien définir le .htaccess et de le mettre à la racine.

 

Bien entendu, je ne sais pas si c'est possible :)

Share this post


Link to post
Share on other sites
thewiseoldman

C'est tout à fait possible

Share this post


Link to post
Share on other sites
Erwin
Un seul petit point négatif, c'est de mettre le .htaccess dans chaque répertoire, je n'y connais rien, mais ça serait mieux de bien définir le .htaccess et de le mettre à la racine.

 

Bien entendu, je ne sais pas si c'est possible :)

 

Les règles du .htaccess sont définies pour le répertoire où il se trouve et tout les sous-répertoire qui s'y trouvent. Si vous placez un .htaccess dans /home/monsite/, les règles seront toujours valable dans /home/monsite/mondossier/.

Share this post


Link to post
Share on other sites
Poppy

Mouarf, bon pas grave, ça marche comme je veux, c'est le principal ^_^

Share this post


Link to post
Share on other sites
Anaïs

Bonsoir,

 

Je lu chaqu'un de vos messages sur ce sujet, je cherche une personne sympa pour bien m'expliquer le .htaccess, car j'ai le même probléme que gregore !

 

En fait mon but est pas de protéger mon forum mais les créations de mon site, tout le monde me prends les URL de mes diverses créations, j'aimerai pouvoir protéger que mon dossier "Avatar" par exemple et je crois avoir comprit qu'on peut !

 

Si vous voulez contacter moi par mail : webmasteur@senteur-myrtille.com

Ou bien par MSN : anais_csm@hotmail.fr

 

Bref par le plus facile pour vous; ou sinon ici je ne vois pas de probléme !

 

Je tiens à dire que je suis chez Online, j'ai rien trouvé sur leur site qui me dit si oui ou non il accepte le .htaccess :P

 

J'éspere que quelqu'un pourra m"aider ! Je ferais même un lien vers le forum pour vous remercier si vous voulez !

Merci d'avance !

 

Anaïs :P

Share this post


Link to post
Share on other sites
guymauve

Bonjour,

 

Moi aussi j'ai un léger souci :

 

Voici mon htaccess:

 

RewriteEngine on
RewriteCond %{HTTP_REFERER} !^$
RewriteCond %{HTTP_REFERER} !^http://(www\.)?mxforum.be/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://(www\.)?forum.mxforum.be/.*$ [NC]
ReWriteRule \.(gif|rar|zip|png|jpe?g)$ - [F]

 

Je l'ai placé à la racine du site. A la racine se trouve l'index.php et les dossiers et sous dossiers de mon forum.

 

Lorsque je linke une image elle apparaît qd même :

 

nav.gif

 

Bref je ne comprends pas où j'ai merdé.

 

Merci de votre aide et bonne journée.

Share this post


Link to post
Share on other sites
Anaïs

S'il vous plait, personne peut m'aider ?

Je me débrouille bien je veux jsute qu'on m'aide à trouver mes erreurs ! :)

 

Moi c'est bien les images apparaissent pas maos par contre ma page non plus et c'est la que je comprends pas ^_^

Edited by Anaïs

Share this post


Link to post
Share on other sites
Melkendar

@Guymauve : ton image n'apparaît pas :)

 

@Anaïs : Que voulez-vous dire par on prend l'url de vos créations? Quelqu'un poste les urls ailleurs? C'est tout? Ou quelqu'un affiche les images ailleurs en utilisant les urls de vos images? SI c'est le cas, il suffit de limiter les sites pouvant lier vos images à leur site.

Share this post


Link to post
Share on other sites
guymauve
@Guymauve : ton image n'apparaît pas ^_^

 

AH bon je vais vider mes fichiers temp alors :)

 

Et pouvez-vous télécharger ceci :

 

test zip

 

 

Merci à vous.

 

A+

Share this post


Link to post
Share on other sites
Anaïs

Bonjour,

 

D'abord merci pour votre réponse !

 

J'offre sur mon site des textures, fonds de pages etc... Et en me visitant je vois un nombre inscroyable de personnes qui affiche mes créations sur le forum ou assisant (voila) en me prenant l'url, donc sa me mange ma bande passante !!!

J'ai fait des avertissements etc... Mais rien à faire je vois des forums décorés à 100% avec les créations que j'offre, bien sur si je les offre ils peuvent les prendre mais pas prendre les URL !!!

 

Donc je voudrais protéger mes dossiers de créations de sorte que quand ils prenont une URL rien ne s'affichera !

 

J'éspere que vous me comprennez !

 

Merci

Share this post


Link to post
Share on other sites
TitaX
AH bon je vais vider mes fichiers temp alors  :)

 

Et pouvez-vous télécharger ceci :

 

test zip

Merci à vous.

 

A+

 

Forbidden

You don't have permission to access /mcm2/nats/amaunadilla.zip on this server.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Share this post


Link to post
Share on other sites
The_ED

Options -Indexes
SetEnvIfNoCase Referer "^www.tonsite.com" yepa
SetEnvIfNoCase Referer "^tonsite.com" yepa
SetEnvIfNoCase Referer "^http://tonsite.com" yepa
SetEnvIfNoCase Referer "^http://www.tonsite.com" yepa
SetEnvIfNoCase Referer "^http://forum.tonsite.com" yepa
SetEnvIf Referer "^$" yepa
<Files ~ "\.(gif|jpg|jpeg|png)$">
order deny,allow
allow from env=yepa
deny from all
</Files>

 

Voila donc tu definis des exceptions, c'est a dire que a partir des ces urls les images seront affichés et pour le reste bah ca ne marchera pas

Share this post


Link to post
Share on other sites
Anaïs

D'accord merci beaucoup !

 

Donc je copie ce code dans un bloc note que je publie et que je rennome : .htaccess ! J'espere que c'est sa ! Je viendrais éditer ce message pour dire si sa a marcher ou pas !

 

-------------------------------------------------------------------

 

Bon sa ne marche pas ! ^_^

 

Les images ne s'affichent pas sa c'est génial mais sur le coup ma page affiche :

 

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@proxad.net and inform them of the time the error occurred, and anything you might have done that may have caused the error.

 

More information about this error may be available in the server error log.

 

Voila mon code :

 

Options -Indexes
SetEnvIfNoCase Referer "^www.senteur-myrtille.com" yepa
SetEnvIfNoCase Referer "^senteur-myrtille.com" yepa
SetEnvIfNoCase Referer "^http://senteur-myrtille.com" yepa
SetEnvIfNoCase Referer "^http://www.senteur-myrtille.com" yepa
SetEnvIfNoCase Referer "^http://99281.aceboard.fr" yepa
SetEnvIf Referer "^$" yepa
<Files ~ "\.(gif|jpg|jpeg|png)$">
order deny,allow
allow from env=yepa
deny from all
</Files>

 

Voila je comprends pas pourquoi :) j'ai publié mon bloc note qui je l'ai rennomé comme je disais plus haut...

Edited by Anaïs

Share this post


Link to post
Share on other sites
The_ED

hum normalement ca marche, peut etre est ce que le serveur de Free est configuré de facon que ca ne marche pas!

 

Pourrais tu detailler un peu plus quand ces erreurs se presentent!

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.