Jump to content
Invision Board France
Sign in to follow this  
thewiseoldman

Protéger ses images et sa bande passante.

Recommended Posts

Chandon

Merci fugitif pour les conseils.

Bon c'est vrai que j'ai laissé à 25p/mn mais je l'essaye à peine... je pense descendre à 15 progressivement, et on verra si ça bloque trop de monde.

Share this post


Link to post
Share on other sites
kizuna

Moi j'avais j'essayer celui proposer par thewiseoldman sur mon forum mais les smileys ne s'afficher plus,ceux qui ont le meme prob voici la solution ::

 

 

RewriteEngine on
RewriteCond %{HTTP_REFERER} !^$
RewriteCond %{HTTP_REFERER} !^http://(www\.)?mon-site.com/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://(www\.)?site-pote.com/.*$ [NC]
ReWriteRule \.(gif|png|jpe?g)$ - [F]

 

ça marche parfaitement aussi,voilà ;)

Edited by kizuna

Share this post


Link to post
Share on other sites
ex-floodeur

les visiteurs qui passent par un proxy ne peuvent voir les images qui sont bloquées par un htacces..

 

comment resoudre cela ?

Share this post


Link to post
Share on other sites
Fabrice

Bonjour,

 

Existe-t-il un script qui permette d'empêcher les membres de son forum de linker d'autres sites ?

 

J'ai désactivé la fonction upload mais je constate que des membres font des liens pour contourner la "difficulté".

 

Je n'ai jamais utilisé un fichier htaccess. On m'a dit qu'une fois uploadé, il était difficile de le supprimer via son éditeur FTP... :huh: C'est vrai ou c'est n'importe quoi ?

 

Merci de vos conseils :)

Share this post


Link to post
Share on other sites
thewiseoldman

Bonjour Fabrice,

 

Non il n'est pas possible de base d'empêcher l'affichage d'images externes.

 

un .htaccess est très facile à supprimer, la seule chose à prévoir est que le client FTP affiche bien les fichiers cachés (qui commencent par un . ) Si on le voit alors il n'est pas plus difficile de supprimer un fichier htaccess qu'un autre fichier.

Share this post


Link to post
Share on other sites
thewiseoldman
les visiteurs qui passent par un proxy ne peuvent voir les images qui sont bloquées par un htacces..

 

comment resoudre cela ?

Le problème doit venir du referrer qui est bloqué.

Share this post


Link to post
Share on other sites
Fabrice
Bonjour Fabrice,

 

Non il n'est pas possible de base d'empêcher l'affichage d'images externes.

 

un .htaccess est très facile à supprimer, la seule chose à prévoir est que le client FTP affiche bien les fichiers cachés (qui commencent par un . ) Si on le voit alors il n'est pas plus difficile de supprimer un fichier htaccess qu'un autre fichier.

Merci Wise.

 

Ok.

 

Si le client FTP n'affiche pas le fichier htaccess, existe-t-il un moyen alternatif pour l'effacer ?

Passer par le serveur par exemple ?

Share this post


Link to post
Share on other sites
thewiseoldman

Oui via le Gestionnaire de fichiers du Cpanel par exemple.

Share this post


Link to post
Share on other sites
QI907

Bonjour, j'ai installé dans htaccess vos systèmes d'anti-aspirateurs et d'anti-pompages d'images par liens. Merci !! ;)

 

Le site externe qui link une image de mon site a une croix rouge ! :dur:

 

Mais je souhaite faire mieux : au lieu de faire apparaître une croix, je souhaite faire apparaître une image. ;)

 

(Cette image devra probablement être hébergée ailleurs, puisque les links de sites extérieurs sont bloqués ? :D )

 

Savez-vous comment faire, le code à insérer, SVP ? Merci ! :oops:

Share this post


Link to post
Share on other sites
thewiseoldman
RewriteEngine on

RewriteCond %{HTTP_REFERER} !^$

RewriteCond %{HTTP_REFERER} !^http://(www\.)?VOTRE_DOMAINE.COM/.*$ [NC]RewriteRule \.(gif|jpg|GIF|JPG|rmi|mid|MID|rm|wav|WAV)$ http://hebergeurgratuit.fr/votre_site_gratuit /banniere.gif [R,L]

 

Pensez à chercher dans les articles que nous avons cités précedemment par exemple Toulouse renaissance.

Share this post


Link to post
Share on other sites
QI907

Merci beaucoup ! :oops:

Share this post


Link to post
Share on other sites
thewiseoldman

[HS]Merci de choisir entre une des deux images dans votre signature mais pas les deux[/HS]

Share this post


Link to post
Share on other sites
LLaumgui
RewriteEngine on

RewriteCond %{HTTP_REFERER} !^$

RewriteCond %{HTTP_REFERER} !^http://(www\.)?VOTRE_DOMAINE.COM/.*$ [NC]

RewriteRule \.(gif|jpg|GIF|JPG|rmi|mid|MID|rm|wav|WAV)$ http://hebergeurgratuit.fr/votre_site_gratuit /banniere.gif [R,L]

Par contre, le cache google, c'est un massacre ---> voir ici.

 

Donc, je pense qu'on doit aussi rajouter cette ligne...:

RewriteCond %{HTTP_REFERER} !^http://google.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.google.*$ [NC]

Vous pensez à d'autres archiveurs ?

Share this post


Link to post
Share on other sites
belline

A la limite...ça donne envie d'aller voir le site le fait qu'il ny ai pas les images dans le cache de Google...

 

Choix difficile...

Share this post


Link to post
Share on other sites
Bismut

Bonjour, j'ai lu quelques dossiers sur le moyen de préserver ses images de redirections d'autres sites et ainsi préserver son traffic mensuel "d'attaques extérieures". Cependant, j'ai quelques soucis...

 

Voici la structure de mes fichiers hébergés :

Racine

- Fichiers .php du site avec notamment un .htaccess controlant les variables globales.

- Dossier "Cartes"

|- Fichier .htaccess dont le code se trouve ci-dessous

|- Sous-dossier "LOB"

|- Images .jpg "LOB-000.jpg", "LOB-001.jpg", etc...

 

Fichier .htaccess se trouvant dans le dossier "Cartes" :

RewriteEngine on
RewriteCond %{HTTP_REFERER} !^$
RewriteCond %{HTTP_REFERER} !^http://www.kingyugi.org/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.kingyugi.org/forum/.*$ [NC]
ReWriteRule .*\.(gif|png|jpe?g)$ - [F]

 

 

Au début, les images s'affichaient, et puis je ne sais pourquoi... elles ne s'affichent plus maintenant ?

De plus, au début... j'ai voulu utiliser une de ces images comme signature pour un autre forum et cela marchait... est-ce normal ? Je pensais justement que ce script était destiné à empêcher d'autres adresses que les miennes à afficher ces images, non ?

 

Mes images ont l'adresse suivante :

http://www.kingyugi.org/Cartes/LOB/LOB-001.jpg

 

Je ne comprends pas pourquoi je suis bloqué étant donné que j'autorise l'accès depuis cette adresse... ?

Quand je veux forcer l'affichage de l'image, je tombe sur :

 

Forbidden

You don't have permission to access /Cartes/LOB/LOB-001.jpg on this server.

 

 

C'est donc bien l'erreur que je veux provoquer chez les autres, mais pas chez moi... ;)

 

Si quelqu'un a déjà connu le même problème... ce serait gentil de m'en faire part... B)

 

 

PS : J'ai lu les liens précedemment donnés mais je ne vois pas d'où vient l'erreur...

;)

 

Merci :blink:

Share this post


Link to post
Share on other sites
Fugitif

La réponse a déjà été donner je pense.

Il faut indiquer a ton fichier .htaccess si tu utilise des répértoires.

 

Donc ajoute ceci a ton fichier .htaccess http://www.kingyugi.org/Cartes/LOB/

 

Edit: j'ai bien donner la réponse ici http://www.invisionboard.fr/forums/index.php?s...indpost&p=44090

Edited by Fugitif

Share this post


Link to post
Share on other sites
Bismut

J'ai modifié mon htaccess comme tu me l'as conseillé et cela ressemble donc à :

 

RewriteEngine on
RewriteCond %{HTTP_REFERER} !^$
RewriteCond %{HTTP_REFERER} !^http://www.kingyugi.org/Cartes/LOB/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.kingyugi.org/Cartes/LON/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.kingyugi.org/Cartes/MRD/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.kingyugi.org/Cartes/MRD-F/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.kingyugi.org/Cartes/MRL/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.kingyugi.org/Cartes/PSV/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.kingyugi.org/forum/.*$ [NC]
ReWriteRule .*\.(gif|png|jpe?g)$ - [F]

 

Malgré tout, cela ne marche toujours pas... ^_^

Dois-je mettre un .htaccess dans chacun de ces sous-répertoires ? D'après ce que j'avais lu, un seul dans "Cartes" devrait suffire pourtant non ? :lol:

 

J'ai oublié quelque chose d'autre ?

Share this post


Link to post
Share on other sites
Fugitif
J'ai modifié mon htaccess comme tu me l'as conseillé et cela ressemble donc à :

 

RewriteEngine on
RewriteCond %{HTTP_REFERER} !^$
RewriteCond %{HTTP_REFERER} !^http://www.kingyugi.org/Cartes/LOB/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.kingyugi.org/Cartes/LON/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.kingyugi.org/Cartes/MRD/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.kingyugi.org/Cartes/MRD-F/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.kingyugi.org/Cartes/MRL/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.kingyugi.org/Cartes/PSV/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.kingyugi.org/forum/.*$ [NC]
ReWriteRule .*\.(gif|png|jpe?g)$ - [F]

 

Malgré tout, cela ne marche toujours pas...  ^_^

Dois-je mettre un .htaccess dans chacun de ces sous-répertoires ? D'après ce que j'avais lu, un seul dans "Cartes" devrait suffire pourtant non ?  :lol:

 

J'ai oublié quelque chose d'autre ?

Normalement un .htaccess se place dans le répertoire que tu veux protéger.

Donc oui il faut en mettre un dans chaque répertoire.

J'avais déjà dit ceci ici http://www.invisionboard.fr/forums/index.php?s...indpost&p=67513

 

Et mauvaise idée d'avoir mis tes répertoires en majuscules.

Sous Linux c'est pas très pratique. Ton problème peu venir de là.

 

Sinon décrit un peu plus se qui ne "marche" pas.

Regarde aussi si ton serveur web a le mod_rewritte activé.

Et relis (ou lis) ce sujet entièrement, car bcp de réponses y sont déjà données.

Edited by Fugitif

Share this post


Link to post
Share on other sites
thewiseoldman

Par défaut un .htaccess protège un dossier et tous les fichiers et sous dossiers.

Share this post


Link to post
Share on other sites
Fugitif
Par défaut un .htaccess protège un dossier et tous les fichiers et sous dossiers.

Ben ceci est je crois valable pour les aspirateurs web, mais pas pour protégé sa bande passante non?

Il me semble avoir fait le test il y a quelques temps pour vérifier, car certains disaient oui, d'autre non, bref c'était pas clair cette histoire.

Edited by Fugitif

Share this post


Link to post
Share on other sites
thewiseoldman

Avant de tester il faut bien vider votre cache et IE est traitre sur ce coup là une fois de plus. Mon .htaccess est au niveau du forums et les émoticônes sont protégés quand même.

Share this post


Link to post
Share on other sites
Bismut

J'ai bien vidé mon cache, mais pas de changements...

J'ai contacté mon hébergeur pour lui demander pour le mode Rewrite, j'attends sa réponse... :lol:

 

Pour le problème : Tout simplement les images des sous-dossiers en question ne s'affichent pas, même chez moi ! C'est ça le problème, c'est TROP efficace...

 

Une fois, j'ai essayé de le mettre à la base même du site je crois, et le site n'était plus accessible, de même que le forum... pas que les images, mais toute la page, c'était l'erreur renvoyée théoriquement : forbidden etc... :huh:

 

Voilà, je ne sais plus trop quoi faire... :)

Share this post


Link to post
Share on other sites
Fugitif

@thewiseoldman

 

Arff j'avais pas penser au cache de IE.

 

 

@Bismut il y a un test pour voir si le mod rewritte est activé. Relis se topic en entier et celui avec le script anti aspirateurs.

Share this post


Link to post
Share on other sites
Bismut

J'ai vu le test, oui... mais je ne pense pas pouvoir le faire, il y a en permanence une 20aine de users sur le forum donc je me fais lincher si je coupe... :rolleyes:

 

Sinon, mon hébergeur m'a répondu en me disant d'ajouter une ligne en haut, voilà donc mon nouveau .htaccess :

 

Options +FollowSymlinks

 

RewriteEngine on

RewriteCond %{HTTP_REFERER} !^$

RewriteCond %{HTTP_REFERER} !^http://www.kingyugi.org/.*$ [NC]RewriteCond %{HTTP_REFERER} !^http://www.kingyugi.org/forum/.*$ [NC]

ReWriteRule .*\.(gif|png|jpe?g|GIF|PNG|JPE?G)$ - [F]

 

 

Maintenant, mes images s'affichent... :lol:

 

Mais j'ai essayé d'utiliser une image que je pensais "protégée" (car dans un de ces dossiers) pour une signature sur un autre forum... et l'image apparaît... :lol:

 

Est-ce normal ? Je pensais que le script était justement fait pour qu'aucun autre adresse ne puisse y accéder.... :lol: non ?

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.