Jump to content
Invision Board France
  • 0
Sign in to follow this  
[LGF] Tatayet

Impossible d'inscrire forum

Question

[LGF] Tatayet

Bonjour,

 

J'ai un problème qui traine depuis pas mal de temps au sujet d'IP.Converge.

 

J'ai deux forums (version 2.3.3)

- http://www.lgf-world.net/team/forum/

- http://www.lgf-world.net/peugeumeu/forum/

 

et l'installation que j'ai refaite ce matin de converge (version 1.0.0)

- http://www.lgf-world.net/converge/

 

Dans converge quand je veux inscrire un nouveau forum, j'ai le message d'erreur: "Incorrect data returned from the local application" . Pourtant les renseignements donnés sont exacts, vu que je fais copier/coller d'un fichier texte.

 

Dans la configuration des forums, j'ai suivis les instructions d'un membre d'un autre forum qui avait le même problème au début:

Log In Title : IP.Converge

Log In Description :

 

Log In Files Folder Name : (url IP CONV) http://www.lgf-world.net/converge

 

Log In User Maintenance URL : (url IP CONV) http://www.lgf-world.net/converge

 

Log In User Register URL :

 

Log In Authentication Type? ON FAIL

 

Log In Form HTML

 

Log In HTML Replace Form : NO

 

Log In User Log In URL

 

Log In User Log Out URL

 

Log In Enabled : YES

 

Log In User Name Type : EMAIL ADRESS

 

Mais aucune amélioration de la situation.

 

Auriez-vous une piste?

 

Merci d'avance et bonne journée.

Share this post


Link to post
Share on other sites

Recommended Posts

  • 0
Youp3

Bonjour

 

je n'ai pour le moment pas eu l'occasion de tester Converge, mais j'ai l'impression qu'il va falloir que je m'y mette. Je te tiens au courant de mes investigations.

Share this post


Link to post
Share on other sites
  • 0
Erwin

Bonsoir,

 

Est-ce que tu as activé IP.Converge dans le PCA des deux forums ?

PCA > Tools & Settings > IP.Converge Configuration : Enable IP.Converge ? 'Yes'

Share this post


Link to post
Share on other sites
  • 0
Erwin

Curieux, j'ai fait une install de Converge en local hier soir, aucun problème, et il n'y a pas besoin de créer une connexion dans IPB...

 

Peux-tu nous dire de quelle façon tu as inscris tes deux forums dans Converge ?

Share this post


Link to post
Share on other sites
  • 0
[LGF] Tatayet

Bonjour,

 

La façon dont j'ai inscrits mes deux forums? J'aimerai déjà en inscrire un.

 

J'ai à peu près tout essayé, mais la manière la plus standard:

 

Product information

http://www.lgf-world.net/peugeumeu/forum/

 

Mon email d'admin et mon mot de passe admin.

 

Et en réponse: Incorrect blablabla...

Share this post


Link to post
Share on other sites
  • 0
Erwin

Bon il va falloir creuser pour savoir ce qui déclenche cette réponse, si toutefois c'est possible (sources obfusquées).

Share this post


Link to post
Share on other sites
  • 0
[LGF] Tatayet
Bon il va falloir creuser pour savoir ce qui déclenche cette réponse, si toutefois c'est possible (sources obfusquées).

 

C'est bon je suis arrivé en Chine. Mais rien de nouveau...

Share this post


Link to post
Share on other sites
  • 0
[LGF] Tatayet

Bonzour,

 

Je me suis décidé à faire des captures d'écran de mes différentes étapes de configurations, car comme on le dit, un image vaut mieux que de grands discours.

 

Voici:

 

Premier forum:

Tools & Settings

 

Log In Manager

 

Détails de Log In IP.Converge

 

Deuxième forum:

Tools & Settings

 

Log In Manager

 

Détails de Log In IP.Converge

 

IP.Converge:

Premier forum dans IP.Converge

 

Deuxième forum dans IP.Converge

 

 

 

Tous les scripts sont en dernière version. Les courriels et mot de passe sont bons. A savoir que l'adresse courriel et compte admin de converge sont différents des comptes admins de chaque forums.

 

Est-ce qu'il y aurait un Père Noël IP.Board qui pourrait m'offrir comme cadeau la solution? (Un Mère Noël aussi, je suis loin d'être contre :drop: )

Share this post


Link to post
Share on other sites
  • 0
Erwin

Bonsoir,

 

Je ne sais pas pourquoi tu es allé dans ces trucs-là, perso j'ai configuré Converge sans avoir à faire un tour dans cette section du PCA.

Share this post


Link to post
Share on other sites
  • 0
[LGF] Tatayet

Depuis, j'ai remis les configurations par défaut et j'ai simplement activé IP.Converge configuration dans Tools & Settings, mais c'est toujours le même résultat dans Converge...

 

Et franchement, je ne vois vraiment pas du tout comment résoudre le problème.

Share this post


Link to post
Share on other sites
  • 0
[LGF] Tatayet

Quelques semaines après...

 

On a pu enfin me trouver la raison du problème décrit ci-dessus que personne ne pouvait m'expliquer. Voici la démarche:

 

J'ai repris 1 an de support auprès d'IPS auquel j'ai soumis le problème, qui après pas mal d'échange ont transmi aux développeurs dIP.Converge qui ont donc testé avec une version non encrypté et qui a donné comme erreur:

 

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<HTML><HEAD>
<TITLE>403 Forbidden</TITLE>
</HEAD><BODY>
<H1>Forbidden</H1>
You don't have permission to access /team/forum/converge_local/converge.php
on this server.<P>
</BODY></HTML>

 

J'ai donc appelé mon hébergeur (Infomaniak) sur sa demande pour que ce soit plus clair. Et après explication, le "ticket" a été transmis à leur technicien qui m'a répondu ceci ce matin:

 

Bonjour,

 

Le problème vient du fait que nous bloquons les requettes POST sans User-Agent. Nous avons fait ce bloquage car il y'a beaucoup de hack avec des clients web sans User-Agent.

 

Il vous faut donc modifier le code ou vous adresser au support pour demander comment rajouter un User-Agent

lors de l'appel de ceci:

 

"POST /team/forum/converge_local/converge.php HTTP/1.0"

 

www.lgf-world.net 84.16.81.36 - - [21/Jan/2008:16:34:18 +0100] "GET /team/forum/converge_local/converge.php?info=1 HTTP/1.0" 200 762 "-" "-"

www.lgf-world.net 84.16.81.36 - - [21/Jan/2008:16:34:18 +0100] "POST /team/forum/converge_local/converge.php HTTP/1.0" 403 236 "-" "-"

www.lgf-world.net 10.3.3.39 - - [21/Jan/2008:16:34:18 +0100] "POST /converge/admin/index.php?adsess=69dfd4c606d23ab2503a0414025a84ea&act=products&section=apps&do=product_add HTTP/1.1" 200 12468 "http://www.lgf-world.net/converge/admin/index.php?adsess=69dfd4c606d23ab2503a0414025a84ea&act=products&section=apps&do=product_add" "Mozilla/5.0 (compatible; Konqueror/3.5) KHTML/3.5.5 (like Gecko)"

www.lgf-world.net 84.16.81.36 - - [21/Jan/2008:16:34:47 +0100] "GET /team/forum/converge_local/converge.php?info=1 HTTP/1.0" 200 762 "-" "-"

www.lgf-world.net 84.16.81.36 - - [21/Jan/2008:16:34:47 +0100] "POST /team/forum/converge_local/converge.php HTTP/1.0" 403 236 "-" "-"

www.lgf-world.net 10.3.3.39 - - [21/Jan/2008:16:34:47 +0100] "POST /converge/admin/index.php?adsess=69dfd4c606d23ab2503a0414025a84ea&act=products&section=apps&do=product_add HTTP/1.1" 200 12468 "http://www.lgf-world.net/converge/admin/index.php?adsess=69dfd4c606d23ab2503a0414025a84ea&act=products&section=apps&do=product_add" "Mozilla/5.0 (compatible; Konqueror/3.5) KHTML/3.5.5 (like Gecko)"

 

Avec mes meilleures salutations,

 

J'ai donc traduits ce courriel que j'ai renvoyé à IPS dans un nouveau ticket. Et là réponse de cet après-midi:

 

Hello,

 

I will log this to our bug tracker to look into in a future version. Unfortunately there is no way to make an intermediary change which will allow the software to work properly on your site, given your host's configuration.

 

http://forums.invisionpower.com/index.php?...g_title_id=8160

 

Please let me know if you have any further questions or concerns. Thanks!

 

Brandon Farber

Invision Power Services, Inc.

 

l'URL donnée est : http://forums.invisionpower.com/index.php?...mp;bug_cat_id=1

 

J'ai répondu que j'étais déçu et que j'espère qu'une prochaine version allait être très bientôt disponible car en attendant mes forums ne peuvent pas fonctionne comme prévus.

 

Il faudra donc attendre la prochaine version de IP.Converge pour voir mon problème résolu.

 

Patiente...

Share this post


Link to post
Share on other sites
  • 0
Youp3

Ce qui est rassurant, c'est que nous ne pouvions pas trouvé la cause de ce problème. :)

Share this post


Link to post
Share on other sites
  • 0
[LGF] Tatayet

Avant que je ne saute dans le support d'IPS tel un fauve sous-alimenté voyant des steak qui dandinent autour de lui, rassurez-moi.

 

http://www.invisionboard.fr/forums/index.php?s...mp;#entry203430

 

C'est passé en FIXED

 

C'est bon signe! Mais alors comment puis l'obtenir ce fixed? C'est dans les cartons de la prochaine version?

Share this post


Link to post
Share on other sites
  • 0
Youp3

Bonjour

 

Etant donné qu'il n'y a rien concernant cela dans la base de connaissances d'IPS, il faut donc attendre la prochaine version du produit.

Share this post


Link to post
Share on other sites
  • 0
[LGF] Tatayet
Hello,

 

1. When next IP.Converge version will be release?

 

We do not have a specific date for the release at this time I am afraid.

 

Ah! Il est afraid.

 

Si même les agent d'IPS ont peur, on est bien parti comme ça...

Share this post


Link to post
Share on other sites
  • 0
Erwin

Non c'est une expression, il n'a pas "peur", comme on peut dire "j'ai bien peur de ne pas pouvoir vous dire quand sortira la prochaine version". C'est la même chose ;) . J'ai bien "peur" que la seule chose à faire soit d'attendre qu'IPS sorte prochainement une nouvelle version d'IP.Converge, qui sait avec la prochaine bêta d'IP.Nexus ? Nous verons bien.

Share this post


Link to post
Share on other sites
  • 0
Youp3
...IPS sorte prochainement une nouvellement version d'IP.Converge.

J'ai bien peur que tu ne sois fatigué pour écrire un tel truc. :)

Share this post


Link to post
Share on other sites
  • 0
Erwin
J'ai bien peur que tu ne sois fatigué pour écrire un tel truc. :drop:

Bien vu :)

Share this post


Link to post
Share on other sites
  • 0
Erwin

C'est bon, la version 1.0.1 est sortie et corrige ton problème :)

Share this post


Link to post
Share on other sites
  • 0
[LGF] Tatayet

Ah oui fiiiiou je suis rassuré:

 

Warning: main(../../invisionboard/trunk/ips_kernel/class_converge.php) [function.main]: failed to open stream: No such file or directory in /home/www/afb2f0b9354322cbde2b8f94f53b890b/web/converge/install/index.php on line 23

Warning: main(../../invisionboard/trunk/ips_kernel/class_converge.php) [function.main]: failed to open stream: No such file or directory in /home/www/afb2f0b9354322cbde2b8f94f53b890b/web/converge/install/index.php on line 23

Warning: main(../../invisionboard/trunk/ips_kernel/class_converge.php) [function.main]: failed to open stream: No such file or directory in /home/www/afb2f0b9354322cbde2b8f94f53b890b/web/converge/install/index.php on line 23

 

J'ai tout effacé IP.Converge et j'ai voulu recommencer sur une base neuve. et donc ce nouveau message d'erreur...

 

Que d'aventure avec IPS. Je n'ai pas vraiment le temps de m'en occupé je vais envoyer un petit tickounet à IPS à moins que vous aillez une idée.

 

Merci pour l'information de la sortie.

Share this post


Link to post
Share on other sites
  • 0
Erwin

Malheureusement IP.Converge est encodé, je ne peux pas voir grand chose... Il faudra effectivement ouvrir un ticket chez IPS.

Share this post


Link to post
Share on other sites
  • 0
[LGF] Tatayet

Tickounette sended!

 

Je vous ferai par des magnifique aventure des LGF et leur IP.Converge!

 

Prépare toi public tu vas rêver!

Share this post


Link to post
Share on other sites
  • 0
[LGF] Tatayet

C'est formidable ce que l'on peut vivre comme émotion avec IPS et ses scripts qui sont livrés pas entièrement finis il me semble!

 

Déjà pour mon problème d'installation IPS a mis en ligne une version buggée lors des premières heures de téléchargement, bingo, j'ai fait parti des clients qui ont plongé à sa sortie...

 

J'ai donc pu importer les membres, mais bien sûr c'était trop beau pour que tout fonctionne! J'ai voulu activer le courriel de validation d'inscription dans IP.Converge et là, youpi! Un magnifique bug.

 

La seule chose qu'est capable d'envoyer converge c'est un courriel avec comme corps de message le seul et unique mot:

 

Array

 

Pratique pour le lien d'activation dans le courriel...

 

J'ai donc continuer sur mon ticket et voici la dernière réponse en date:

 

Hello,

 

I believe there is a bug in the emailer code. I haven't added a fix to your installation. I will be working with the other developers to have this cleared for the next revision.

 

Thank You,

Jason Lombardozzi

Web Application Developer

Invision Power Services, Inc.

 

Génial! ils believe les gens d'IPS...

 

Donc: I BELIEVE I CAN FLYYYYYY I BELIEVE, I CAN TOUCH THE BOARD!

 

Et il vont working...

 

Ca fait des mois que j'attends la version 1.0.1 d'IP.Converge et à sa sortie, je suis forcé de nouveau d'attendre une version 1.0.2... Ca commence à franchement m'énerver! En attendant mes sites ne sont pas fonctionnels comme je l'avais projeté.

 

Le Bug Tracker (l'élément le plus amortie d'IPS... malgré qu'il soit gratuit)

http://forums.invisionpower.com/index.php?...;showissue=8673

Share this post


Link to post
Share on other sites
  • 0
Youp3

Juste un mot : magnifique !

 

Courage Tatayet

Share this post


Link to post
Share on other sites
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.