Jump to content
Invision Board France
Sign in to follow this  
Erwin

IP.Board 2.3.1 et IP.Converge 1.0.0 RC 1 disponibles

Recommended Posts

HimSelf

Hi,

 

perso je trouve aussi l'annonce dans l'admin 2.3 nettement plus sobre & toute aussi efficace que préalablement.

Maintenant reste à remettre les dates en français... !

Share this post


Link to post
Share on other sites
FabienC

Bonjour à tous,

Attention, tout dépendant l'heure que vous avez téléchargé le pack d'upgrade et le pack full. Les deux peuvent contenir des bugs. 1 au niveau du fichier class_post_reply.php (solution dispo dans le bugtracker d'IPS et ici) et l'autre, vient que le pack d'upgrade contenait un fichier pas à jour.
Je crois qu'on est en train de battre des records de non-qualité chez IPS.

 

Et aussi des records de manque d'attention pour le client.

Ils sortent une 2.3.1 quelques jours après la 2.3.0 tellement celle-ci était pourrie, mais quand je vais sur le download center, je n'ai même pas un pack d'upgrade de la 2.2.2 vers la 2.3.1…

 

Et comme j'ai vu que Darken avait déjà publié des patchs pour ladite 2.3.1  (merci !), je me demande quelle version il faut attendre pour avoir quelque chose de potable. 2.3.7 ? :)

 

En tout cas, IPS pourrait prendre exemple ici où est fait du magnifique boulot. Merci encore.

Fabien-C

Share this post


Link to post
Share on other sites
Darken

Salut FabienC,

 

Je dirais que le passage entre la v2.2.2 se passe bien. Si par exemple, vous êtiez sous la v2.1.7, j'aurais dis de patienter un peu avant de vous lancer dans ce voyage dans les abyss de l'erreur et des bugs. Mais là vous êtes sous la v2.2.2 et personnellement, je trouve la branche 2.2.x pour buggué que la v2.3.x. Pour la v2.3.0, je suis passé dessus et grosso-modo, c'était correct mais il fallait courrir après les fix non-officiels dans le bug tracker d'IPS. Ensuite, la v2.3.1 est sortie et ça fonctionne parfaitement sauf pour les deux erreurs que j'avais lu chez IPS. Pour celà que j'avais patienté quelques heures et un test en local avant de plonger sous la v2.3.1.

 

Pour la mise à jour entre une v2.2.2 à 2.3.1, hummmm, regarder le nombre de fichier à mettre à jour. Je crois qu'il y au minimum 80 fichiers et plus à mettre à jour. Bref, autant prendre le pack full et faire la mise à jour avec l'aide de WinMerge. :)

Share this post


Link to post
Share on other sites
dohogahs

Pourquoi ne pas faire 2.2.2 > 2.3.0 > 2.3.1

 

Ca serait plus simple encore. :)

Share this post


Link to post
Share on other sites
Youp3

Non ce ne serait pas plus simple. Il y a tellement de changement entre la branche 2.2 et 2.3 qu'aucun pack d'upgrade entre ces deux branches ne sera publié par IPS. Donc le passage de l'une à l'autre devant se faire par un pack 2.3.x complet, autant le faire avec la dernière version 2.3.1.

Share this post


Link to post
Share on other sites
Darken

D'ailleurs, aussi vu que chaque mise à jour majeure doit aussi passer par un rebuild des posts. Sauf si la mise à jour est mineure et qu'il n'y a pas de changement au niveau du core du bbcode. Ce que le passage entre la v2.2.2 a demandé obligatoirement un rebuild complet de posts, évènements des calendrier, signatures, annonces,... pour la v2.3.0. Alors, que la v2.3.0 possède un bug au niveau du snapback legacy où le bbcode est broken, il fallait refaire un rebuild pour la v2.3.1...

 

Bref, passer directement d'un version à la dernière est toujours le mieux vu que l'upgrader va le faire directement :

 

Version History (Last 5)

2.3.1 (23004) 2007-06-20, 20:42

2.3.0 (23003) 2007-06-14, 2:33

2.3.0 RC 2 (23002) 2007-06-14, 2:32

2.3.0 BETA 1 (23000) 2007-06-14, 2:32

2.2.2 (22011) 2007-02-23, 22:21

 

Il y a bien la beta 1 et RC2 dans ma liste mais j'ai jamais installé ces versions. Alors, faut pas se prendre la tête à faire deux màj de suite séparément au lieu d'une seule. :)

Edited by Darken

Share this post


Link to post
Share on other sites
magicmimi

Ils ont prévus de mettre en ligne une nouvelle version toutes les semaines ?

 

Je finis par trouvé cela "usant" ... ferait mieux de sortir une version une fois par an mais abouti et sans bugs ....

C'est pour cela que j'attends au moins 6 mois avant de passer a une version supérieur

 

 

non ?

 

jean-mi

Share this post


Link to post
Share on other sites
uioltehreeth

C'est un produit payant, une majorité des clients veut des améliorations régulièrement, maintenant, il est bon de dire que les mises à jour comme la 2.3.1 ça se fait en 2 minutes, rien de dramatique, je préfère qu'ils corrigent les bugs plutôt que de sortir des patchs qui eux prennent du temps à être appliqués !

 

Chacun est libre après de mettre à jour ou non... certaines versions sont stables, on peut y rester quelques mois sans le moindre problème.

Edited by uioltehreeth

Share this post


Link to post
Share on other sites
Youp3

Je n'ai d'ailleurs pas compris pourquoi tu étais parti sur une 2.2 magic.m

Share this post


Link to post
Share on other sites
Darken
non ?

Pas du tout !! :bien:

Share this post


Link to post
Share on other sites
Mediterranneo

Bonjour,

 

Je viens de demander des conseils de mises-à-jours chez IPS.

 

Jason me répond:

 

If you were upgraded from version 2.2.2 or previous you will need to log into your Admin CP and run: Tools and Settings->Recount and Rebuild->Rebuild Content - All

 

This is required for custom BBCode to function.

 

If you were upgraded from 2.3.0 or higher, this step is not necessary.

 

C'est la première fois que je vois ce type de réponse...

 

- Que cela signfie?

- Pourquoi?

- Explications?

 

Merci d'avance pour vos lanternes - bon dimanche :drop:

Edited by Mediterranneo

Share this post


Link to post
Share on other sites
Youp3

Bonjour

 

Darken l'a déjà expliqué me semble-t-il, mais je n'arrive pas à remettre la main sur son message. Cette nécessité de reconstruire les sujets devait d'ailleurs aussi être faite entre la 2.3 et la 2.3.1. Pourquoi ? Tout simplement parce que la 2.3.x apporte des modifications quant au stockage des messages et que maintenant c'est le message entièrement tel qu'il sera affiché qui est stocké dans la base de données, alors qu'avant il fallait parser les BBCodes pour les transformer en HTML. Si ce n'est pas exactement ça, c'est un truc dans le genre.

Share this post


Link to post
Share on other sites
Fabien

C'est juste les BBCodes persos qui devaient être convertis en HTML pour chaque message avant IP.Board 2.3.

Maintenant, si l'on modifie un BBCode perso, il faut reconstruire tous les messages...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.